Вопрос задан 25.01.2020 в 13:00.
Предмет Информатика.
Спрашивает Омирсериков Омирбек.
Срочно! Написать в Pascal ABC Дано N чисел. Найти самое большое число, на которое делятся все N
чисел. Входные данные В первой строке дано число N. Во второй строке даны через пробел N чисел (1 <= N <= 1000). Выходные данные Выведите искомое числоОтветы на вопрос
Отвечает Бурый Данил.
Var a: array of integer;
i, n, x, digit: integer;
b1, b2: boolean;
begin
readln(n);
setlength(a, n);
for i := 0 to n - 1 do readln(a[i]);
b1 := true;
x := 1;
digit := x;
while b1 do begin
if b2 then digit := x;
inc(x);
b2 := true;
for i := 0 to n - 1 do begin
if (abs(a[i]) < x) and (a[i] <> 0) then begin b1 := false;break; end
else if a[i] mod x <> 0 then begin b2 := false;break; end
end;
end;
write(digit);
end.
i, n, x, digit: integer;
b1, b2: boolean;
begin
readln(n);
setlength(a, n);
for i := 0 to n - 1 do readln(a[i]);
b1 := true;
x := 1;
digit := x;
while b1 do begin
if b2 then digit := x;
inc(x);
b2 := true;
for i := 0 to n - 1 do begin
if (abs(a[i]) < x) and (a[i] <> 0) then begin b1 := false;break; end
else if a[i] mod x <> 0 then begin b2 := false;break; end
end;
end;
write(digit);
end.
Топ вопросов за вчера в категории Информатика
Информатика 17
Информатика 40
Информатика 27
Информатика 61
Информатика 10
Информатика 13
Информатика 42
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
