Вопрос задан 22.01.2020 в 03:50.
Предмет Информатика.
Спрашивает Субботин Владислав.
Написать программу в Pascal. Из предложения вывести слова с заданным количеством слогов.
Ответы на вопрос
Отвечает Бабаев Руслан.
Количество слогов считаем по количеству гласных букв в слове.
Program pr;
uses crt;
var str,s: string;
a,i,j,len,k,kslog: byte;
Begin
Writeln('Введите предложение');
readln(str);
Writeln('Введите кол-во слогов');
readln(k);
Writeln('Слова с ',k,' слогами:');
Writeln;
len:=length(str);
a:=0;
kslog:=0;
for i:=1 to len do
Begin
if (str[i] = ' ') then
Begin
s:=copy(str,i+1,a);
for j:=1 to length(s) do
Begin
if s[j] in ['А','О','У','Э','Ы','Я','Ё','Ю','Е','И','а','о','у','э','ы','я','ё','ю','е','и'] then inc(kslog);
end;
if (k=kslog) then Writeln(s);
kslog:=0;
a:=0;
end
else a:=a+1;
end;
Writeln;
Writeln('Для завершения программы нажмите Enter');
readln;
end.
Program pr;
uses crt;
var str,s: string;
a,i,j,len,k,kslog: byte;
Begin
Writeln('Введите предложение');
readln(str);
Writeln('Введите кол-во слогов');
readln(k);
Writeln('Слова с ',k,' слогами:');
Writeln;
len:=length(str);
a:=0;
kslog:=0;
for i:=1 to len do
Begin
if (str[i] = ' ') then
Begin
s:=copy(str,i+1,a);
for j:=1 to length(s) do
Begin
if s[j] in ['А','О','У','Э','Ы','Я','Ё','Ю','Е','И','а','о','у','э','ы','я','ё','ю','е','и'] then inc(kslog);
end;
if (k=kslog) then Writeln(s);
kslog:=0;
a:=0;
end
else a:=a+1;
end;
Writeln;
Writeln('Для завершения программы нажмите Enter');
readln;
end.
Топ вопросов за вчера в категории Информатика
Информатика 22
Информатика 36
Информатика 60
Информатика 2166
Информатика 10
Информатика 571
Информатика 49
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
