Вопрос задан 21.01.2020 в 21:38. Предмет Информатика. Спрашивает Духленкова Анастасия.

Задача. Паскаль. Почему это решение не верно? Студент Валера являет собой классический пример

лентяя. На занятия он практически не ходит, и только в конце семестра появляется в университете и сдает ”хвосты”. Его заветная мечта: найти такой день, когда можно будет сдать сразу все долги. У него есть расписание работы преподавателей, из которого точно известно, с какого и по какой день месяца каждый преподаватель ежедневно будет доступен. Помогите Валере написать программу, которая по расписанию будет определять, сможет ли Валера сдать все долги за один день или нет. var i,max,min,n:integer; a,b:array[1..100]of integer; begin read(n); max:=0; min:=32; for i:=1 to n do begin read(a[i],b[i]); if a[i]>max then max:=a[i]; if b[i] end; if min>max then writeln('YES') else writeln('NO'); end.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Буторина Аля.
Var
a,b:array[1..100]of integer; 
i,max,min,n:integer; 

begin 
readln(n);
max:=0; min:=32;
for i:=1 to n do 
begin
readln(a[i],b[i]); 
if a[i]>max then max:=a[i]; 
if b[i]<min then min:=b[i];
end; 
if min>=max then
writeln('YES') 
else writeln('NO'); 
end.

Пример:
3
1 5
3 10
4 14
YES
0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос