Составить программу. Ввести три дробных (вещественных) числа и выбрать среди них наибольшее и
вывести его на экран. пы.сы.информатика,паскаль. срочно,срочно,помогите,пожалуйста!!Ответы на вопрос
begin
read(a, b, c);
writeln(max(a,max(b,c)));
end.
или
var a,b,c:real;
begin
read(a, b, c);
if (a>=b) and (a>=c) then write(a)
else if (b>=a) and(b>=c) then write(b) else write(c);
end.
Программа на языке Паскаль, которая позволяет ввести три дробных числа и выбрать среди них наибольшее, может выглядеть следующим образом:
``` program MaxNumber;
var num1, num2, num3, max: real; // объявляем переменные
begin // вводим три дробных числа write('Введите первое число: '); readln(num1); write('Введите второе число: '); readln(num2); write('Введите третье число: '); readln(num3);
// выбираем наибольшее число max := num1; if num2 > max then max := num2; if num3 > max then max := num3;
// выводим наибольшее число на экран writeln('Наибольшее число: ', max);
end. ```
В данной программе мы сначала объявляем переменные `num1`, `num2`, `num3` и `max` как вещественные числа. Затем пользователь вводит три числа с помощью функции `readln`. Далее мы сравниваем каждое число с переменной `max` и, если оно больше, присваиваем его значение переменной `max`. В конце программы выводим наибольшее число на экран с помощью `writeln`.
Надеюсь, это поможет вам. Удачи!
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
