Составьте программу, которая находит позицию запятой в строке s, состоящей из двух слов,
разделенных запятой. Строка вводится с клавиатуры. Пример ввода: Здравствуйте ребята { строка s } Пример вывода: 13 Помогите, пожалуйста.Ответы на вопрос
uses crt;
var s:string;
BEGIN
ClrScr;
readln(s);
writeln(Pos(',', s));
readln;
end.
Конечно, вот пример программы на языке Python, которая выполняет задачу по поиску позиции запятой в строке, состоящей из двух слов, разделенных запятой:
```python # Ввод строки с клавиатуры s = input("Введите строку из двух слов, разделенных запятой: ")
# Ищем позицию запятой в строке position = s.find(',')
# Выводим результат if position != -1: print("Позиция запятой в строке:", position + 1) else: print("Запятая не найдена в строке.") ```
Пример использования программы: ``` Введите строку из двух слов, разделенных запятой: Здравствуйте, ребята Позиция запятой в строке: 13 ```
Программа использует метод `find()` для поиска позиции запятой в строке. Если запятая найдена, то выводится ее позиция (индекс), увеличенная на 1 (так как индексация в Python начинается с 0). Если запятая не найдена, выводится соответствующее сообщение.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
