Pascal ABC:Дано натуральное число.Напишите программу, которая проверяет, является ли оно
трёхзначным и кратна ли 7 сумма его цифр.Ответы на вопрос
Pascal p1;
Var a,b,c,d:integer;
Begin
Readln(a);
B:=a mod 10;
C:= a div 10 mod 10;
D:=a mod 100 div 10;
If (a>=100) and (a<1000) then writeln ('трехзначное')
else writeln('не трехзначное');
If b+c+d mod 7=0 then writeln ('сумма кратна семи')
else writeln ('сумма не кратна семи');
End.
Сложненько, так как не особо поняла, что от нас хотят, извините, если не так
Конечно, вот пример программы на Pascal ABC, которая выполняет указанную задачу:
```pascal program CheckNumber;
var inputNumber, digitSum: integer;
begin // Вводим натуральное число write('Введите натуральное число: '); readln(inputNumber);
// Проверяем, является ли число трёхзначным if (inputNumber >= 100) and (inputNumber <= 999) then begin // Вычисляем сумму цифр числа digitSum := 0; digitSum := digitSum + inputNumber mod 10; // Получаем последнюю цифру inputNumber := inputNumber div 10; // Убираем последнюю цифру digitSum := digitSum + inputNumber mod 10; // Получаем следующую цифру inputNumber := inputNumber div 10; // Убираем следующую цифру digitSum := digitSum + inputNumber; // Получаем первую цифру
// Проверяем, кратна ли сумма цифр числа 7 if digitSum mod 7 = 0 then writeln('Число трёхзначное и кратно 7 сумма его цифр.') else writeln('Число трёхзначное, но сумма его цифр не кратна 7.'); end else writeln('Число не трёхзначное.'); end. ```
Программа сначала запрашивает у пользователя ввод натурального числа. Затем она проверяет, является ли введенное число трёхзначным. Если это так, программа вычисляет сумму его цифр и проверяет, кратна ли эта сумма числу 7. В результате программа выводит соответствующее сообщение.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
