 
Написать программу в С++ Описать функцию Otr(Ax,Bx,Ay,By) вещественного типа находящую длину
отрезка AB на плоскости по координатам его концов |AB|=sqrt((Ax-Bx)^2+(Ay-By)^2 )(Ax,Ay,Bx,By)- вещественны параметры) с помощью этой функции найти длины отрезков AB,AC,AD, если с клавиатуры заданы координаты точек, A,B,C,D. 0
        0
         0
        0
    Ответы на вопрос
 
        #include <iostream>
#include <cmath>
using namespace std;
double Otr(double Ax, double Bx, double Ay, double By) {
return sqrt((Bx - Ax)*(Bx - Ax) + (By - Ay)*(By - Ay));
}
int main() {
double Ax, Ay, Bx, By, Cx, Cy, Dx, Dy;
cin >> Ax >> Ay >> Bx >> By >> Cx >> Cy >> Dx >> Dy;
cout << "|AB|=" << Otr(Ax, Bx, Ay, By) << endl;
cout << "|AC|=" << Otr(Ax, Cx, Ay, Cy) << endl;
cout << "|AD|=" << Otr(Ax, Dx, Ay, Dy) << endl;
return 0;
}
 0
                    0
                     0
                    0
                 
            Программа на языке C++ для нахождения длины отрезка AB и других отрезков AC и AD:
```cpp
#include 
// Функция для нахождения длины отрезка AB double otr(double ax, double bx, double ay, double by) { return sqrt(pow(ax - bx, 2) + pow(ay - by, 2)); }
int main() { double ax, bx, ay, by, cx, cy, dx, dy;
std::cout << "Введите координаты точки A (ax, ay): "; std::cin >> ax >> ay; std::cout << "Введите координаты точки B (bx, by): "; std::cin >> bx >> by; std::cout << "Введите координаты точки C (cx, cy): "; std::cin >> cx >> cy; std::cout << "Введите координаты точки D (dx, dy): "; std::cin >> dx >> dy;
// Нахождение длин отрезков double ab = otr(ax, bx, ay, by); double ac = otr(ax, cx, ay, cy); double ad = otr(ax, dx, ay, dy);
std::cout << "Длина отрезка AB: " << ab << std::endl; std::cout << "Длина отрезка AC: " << ac << std::endl; std::cout << "Длина отрезка AD: " << ad << std::endl;
return 0; } ```
Данная программа принимает с клавиатуры координаты четырех точек A, B, C и D. Затем с помощью функции `otr()` вычисляются длины отрезков AB, AC и AD. Результаты выводятся на экран. Функция `otr()` принимает координаты концов отрезка (xA, yA) и (xB, yB) вещественного типа и возвращает длину отрезка AB по формуле |AB| = sqrt((xA - xB)^2 + (yA - yB)^2).
Пример работы программы:
``` Введите координаты точки A (ax, ay): 0 0 Введите координаты точки B (bx, by): 3 4 Введите координаты точки C (cx, cy): 1 1 Введите координаты точки D (dx, dy): 6 8 Длина отрезка AB: 5 Длина отрезка AC: 1.41421 Длина отрезка AD: 10 ```
 0
                    0
                     0
                    0
                Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			