Кому не сложно помочь с PascalABC? Дана строка. Некоторые из слов взяты в круглые скобки. Написать
программу, выводящую исходную строку без скобок.Ответы на вопрос
Begin
Readln(S);
While Pos('(',S)>0 do Delete(S,Pos('(',S),1);
While Pos(')',S)>0 do Delete(S,Pos(')',S),1);
Writeln(S);
end.
Кому несложно помочь с PascalABC?
Если вам дана строка, содержащая слова, обрамленные круглыми скобками, и вы хотите написать программу, выводящую исходную строку без скобок, вам необходимо применить некоторые встроенные функции для работы со строками в PascalABC.
Программа должна выполнить следующие шаги:
1. Объявите переменную типа `string`, которая будет содержать исходную строку. 2. Прочитайте исходную строку от пользователя или задайте ее напрямую в коде программы. 3. Используя функцию `Pos`, найдите позицию первой открывающей скобки в строке. Функция `Pos` возвращает индекс первого вхождения символа или подстроки в заданной строке. 4. Используя функцию `PosEx`, найдите позицию закрывающей скобки, начиная с позиции, следующей после открывающей скобки. Функция `PosEx` делает то же самое, что и `Pos`, но начиная с указанной позиции в строке. 5. С использованием функции `Copy`, выведите исходную строку без скобок. Функция `Copy` возвращает подстроку из заданной строки, начиная с указанной позиции и определенной длины. 6. Повторите шаги с 3 по 5 до тех пор, пока находятся открывающие и закрывающие скобки. 7. Выведите полученную строку без скобок.
Пример кода:
```pascal program RemoveBrackets; uses SysUtils;
var inputString, outputString: string; openBracketPos, closeBracketPos: integer;
begin writeln('Введите исходную строку:'); readln(inputString);
outputString := inputString; openBracketPos := Pos('(', outputString);
while openBracketPos > 0 do begin closeBracketPos := PosEx(')', outputString, openBracketPos + 1);
if closeBracketPos > 0 then Delete(outputString, openBracketPos, closeBracketPos - openBracketPos + 1);
openBracketPos := Pos('(', outputString); end;
writeln('Строка без скобок:'); writeln(outputString); end. ```
При запуске программы она попросит вас ввести исходную строку. Далее программа удалит все скобки и выведет полученную строку без них.
Например, если введенная строка равна "Привет (мир)", программа выведет "Привет мир".
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
