
Вопрос задан 17.01.2020 в 22:08.
Предмет Информатика.
Спрашивает Капланян Ирина.
РЕШАТЬ ЧЕРЕЗ ПАСКАЛЬ! Даны числа n и m. Создайте массив A[n][m] и заполните его змейкой (см.
пример). Входные данные Программа получает на вход два числа n и m. Выходные данные Программа должна вывести полученный массив, отводя на вывод каждого числа ровно 3 символа. Примеры входные данные 4 10 выходные данные 0 1 2 3 4 5 6 7 8 9 19 18 17 16 15 14 13 12 11 10 20 21 22 23 24 25 26 27 28 29 39 38 37 36 35 34 33 32 31 30 Я написала программу всё правильно ,но она начинается не с нуля помогите исправьте ошибку: var a:array[1..100,1..100] of integer; i,j,n,m:integer; begin readln(n,m); for i:=1 to n do begin for j:=1 to m do begin if i mod 2=1 then a[i,j]:=(i-1)*m+j else a[i,j]:=i*m-j+1; write(a[i,j]:3); end; writeln; end; end. 4 10 1 2 3 4 5 6 7 8 9 10 20 19 18 17 16 15 14 13 12 11 21 22 23 24 25 26 27 28 29 30 40 39 38 37 36 35 34 33 32 31

Ответы на вопрос

Отвечает Иванченко Ростик.
Попробуй начать цикл с i не с 1, а с 0



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Я могу помочь вам с решением задачи по программированию на языке Паскаль. Ваша программа почти правильная, но есть одна маленькая ошибка. Вы начинаете заполнять массив с единицы, а не с нуля, поэтому все числа на единицу больше, чем нужно. Чтобы исправить это, вам нужно вычесть единицу из каждого элемента массива. Вот исправленный код:
var a:array[1..100,1..100] of integer; i,j,n,m:integer; begin readln(n,m); for i:=1 to n do begin for j:=1 to m do begin if i mod 2=1 then a[i,j]:=(i-1)*m+j-1 else a[i,j]:=i*m-j; write(a[i,j]:3); end; writeln; end; end.
Вывод программы будет таким:
0 1 2 3 4 5 6 7 8 9 19 18 17 16 15 14 13 12 11 10 20 21 22 23 24 25 26 27 28 29 39 38 37 36 35 34 33 32 31 30
Надеюсь, это поможет вам. Удачи!


Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili