Вопрос задан 17.01.2020 в 14:04. Предмет Информатика. Спрашивает Аверин Макс.

Написать программу которая выводит пример на умножение однозначных чисел если не правильно то пишет

не правильно и верный ответ ,а если правильно то правильно
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Филиппова Ульяна.
Var
  k,m,n:integer;
begin
  Writeln('Проверка знания таблицы умножения');
  Writeln('Вводите ответ или 0 для окончания работы');
  Randomize;
  repeat
    k:=Random(9)+1;
    m:=Random(9)+1;
    Write(k,' x ',m,' = '); Read(n);
    if n<>0 then
      if n=k*m then Writeln('Верно!')
      else Writeln('Неверно, ответ ',k*m)
  until n=0;
  Writeln('Всего доброго, приходите еще!')
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Я могу помочь вам написать программу, которая выводит пример на умножение однозначных чисел и проверяет правильность ответа. Вот пример такой программы на языке Python:

```python # Импортируем модуль random для генерации случайных чисел import random

# Задаем диапазон однозначных чисел от 1 до 9 min = 1 max = 9

# Генерируем два случайных числа в этом диапазоне a = random.randint(min, max) b = random.randint(min, max)

# Вычисляем правильный ответ answer = a * b

# Выводим пример на умножение на экран print(f"Сколько будет {a} * {b}?")

# Запрашиваем ответ от пользователя user_input = input("Введите ваш ответ: ")

# Проверяем, является ли введенный ответ числом try: user_answer = int(user_input) except ValueError: print("Это не число!") exit()

# Сравниваем ответ пользователя с правильным ответом if user_answer == answer: print("Правильно!") else: print(f"Неправильно! Верный ответ: {answer}") ```

Вы можете запустить эту программу в онлайн-редакторе, например, [Repl.it], и проверить ее работу. Надеюсь, это поможет вам.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос