Вопрос задан 17.01.2020 в 08:01. Предмет Информатика. Спрашивает Самарин Коля.

Написать программу в Паскале.Товар стоит a руб. b коп. За него заплатили c руб. d коп. Сколько

сдачи требуется получить? Вводятся 4 числа: a, b, c и d. Необходимо вывести 2 числа: e и f, число рублей и копеек, соответственно.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Солодов Арсений.
Вот, по идее правильно!
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот пример программы на языке Паскаль, которая решает задачу о сдаче:

```pascal program Change; var a, b, c

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Я могу помочь вам написать программу на Паскале, которая решает задачу о сдаче. Вот возможный вариант кода:

program Change; var a, b, c, d, e, f: integer; begin writeln('Введите стоимость товара в рублях и копейках:'); readln(a, b); // считываем стоимость товара writeln('Введите сумму, которую заплатили за товар в рублях и копейках:'); readln(c, d); // считываем сумму, которую заплатили e := c - a; // вычисляем разницу в рублях f := d - b; // вычисляем разницу в копейках if f < 0 then // если копеек не хватает begin e := e - 1; // уменьшаем рубли на 1 f := f + 100; // прибавляем 100 копеек end; writeln('Сдача составляет ', e, ' рублей и ', f, ' копеек'); // выводим результат end.

Вы можете запустить эту программу в онлайн-компиляторе Паскаля, например, [здесь]. Надеюсь, это было полезно.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос