Напишите программу на Pascal. Нужно ввести число (любое) и должно выдавать, что оно больше, меньше
или равно 10-ти. Притом, что должно быть две строчки с if, а не три.Ответы на вопрос
PascalABC.NET 3.4.2, сборка 1864 от 11.11.2018
Внимание! Если программа не работает, обновите версию!
begin
var x := ReadReal;
if x < 10 then Print('Число меньше 10')
else
if x = 10 then Print('Число равно 10')
else Print('Число больше 10')
end.
Program AddNums(output);
var x:integer;
begin
readln(x);
x:=x-10;
if x<>0 then
if x>0 then
writeln('bolshe 10')
else writeln('menshe 10')
else writeln('ravno 10')
end.
Конечно, вот пример программы на Pascal, которая выполняет указанную задачу:
```pascal program CompareToTen;
var userInput: integer;
begin // Ввод числа с клавиатуры write('Введите число: '); readln(userInput);
// Сравнение числа с 10 и вывод результата if userInput > 10 then writeln('Число больше 10') else if userInput < 10 then writeln('Число меньше 10') else writeln('Число равно 10');
readln; // Чтобы консольное окно не закрывалось сразу end. ```
Эта программа вводит число с клавиатуры, сравнивает его с 10 и выводит соответствующее сообщение. Обратите внимание, что в данном коде используется две строчки с `if`, как вы требовали.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
