Вопрос задан 29.05.2018 в 03:19.
Предмет Информатика.
Спрашивает Смирнова Полина.
Язык программирования: Паскаль. Написать программу.Заполнить массив из 10 элементов случайными
числами в интервале [0..100] и отсортировать первую половину по возрастанию, а вторую – по убыванию.Ответы на вопрос
Отвечает Афанасьева Анна.
var a:array[1..10]of integer;
i,j,k:integer;
begin
for i:=1 to 10 do a[i]:=random(101);
for i:=1 to 10 do write(a[i],' ');
writeln;
for i:=1 to 5 do
for j:=1 to 4 do
if a[j]>a[j+1] then begin
k:=a[j];
a[j]:=a[j+1];
a[j+1]:=k;
end;
for i:=1 to 5 do
for j:=7 to 10 do
if a[j]>a[j-1] then begin
k:=a[j];
a[j]:=a[j-1];
a[j-1]:=k;
end;
for i:=1 to 10 do write(a[i],' ');
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
