Вопрос задан 15.01.2020 в 23:24. Предмет Информатика. Спрашивает Иващенко-Трегубов Никита.

Помогите составить программу на python!! В небоскрёбе n этажей и 1 подъезд,на каждом этаже по 3

квартиры,лифт останавливается только на не чётных этажах .Человек садится в лифт и нажимает номер нужной ему квартиры.На какой этаж дома довезёт лифт человека.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Бобрышов Кирилл.
# Python 3.X

'''
В небоскрёбе n этажей и 1 подъезд,
на каждом этаже по 3 квартиры,
лифт останавливается только
на нечётных этажах. Человек садится
в лифт и нажимает номер нужной
ему квартиры. На какой этаж
дома довезёт лифт человека?
'''

n = int(input('n = '))
ap_to = int(input('Номер квартиры: '))
rem_floor = 1 if ap_to % 3 > 0 else 0
floor_ap_to = ap_to // 3 + rem_floor
if floor_ap_to > n:
    raise ValueError('Такой квартиры нет!')
elif floor_ap_to % 2 == 0:
    print('Лифт довезёт человека либо на {} этаж (придётся подняться на 1 этаж по лестнице,'.format(floor_ap_to -1))
    print('либо на {} этаж, и на 1 этаж придётся спуститься.'.format(floor_ap_to + 1))
else:
    print('Лифт довезёт человека на нужный этаж.')
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа на Python для определения этажа, на котором остановится лифт, принимая во внимание номер нужной квартиры:

```python def calculate_floor(flat_number): floor = (flat_number - 1) // 3 + 1 if floor % 2 == 0: return floor - 1 else: return floor

# Ввод номера нужной квартиры flat_number = int(input("Введите номер квартиры: "))

# Вызов функции для определения этажа floor = calculate_floor(flat_number)

# Вывод результата print("Лифт довезет вас на", floor, "этаж") ```

Программа предлагает пользователю ввести номер нужной квартиры. Затем вызывается функция `calculate_floor`, которая по номеру квартиры определяет этаж, на котором находится квартира. Если этаж четный, то функция возвращает предыдущий нечетный этаж, так как лифт останавливается только на нечетных этажах. Результат выводится на экран.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос