Напишите программу в паскале,пожалуйста Ввести двузначное число a. Поменять цифры числа местами.
Ответы на вопрос
var
n,a,b: integer;
begin
writeln('Введите двузначное число');
readln(n);
a:=n div 10;
b:=n mod 10;
writeln('Полученное число ', b,a);
end.
Конечно, я могу помочь вам написать программу на Pascal, которая меняет местами цифры двузначного числа. Вот пример такой программы:
``` program SwapDigits;
var a, tens, units, swapped: integer;
begin // Ввод двузначного числа write('Введите двузначное число: '); readln(a); // Проверка на двузначность числа if (a < 10) or (a > 99) then begin writeln('Ошибка! Введите двузначное число.'); exit; end; // Разделение числа на десятки и единицы tens := a div 10; units := a mod 10; // Меняем цифры местами swapped := units * 10 + tens; // Вывод результата writeln('Число после замены цифр: ', swapped); end. ```
Эта программа принимает двузначное число от пользователя и затем меняет местами его цифры. Например, если пользователь введет число 47, программа выведет число 74.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
