 
Написать программу, которая проверяет – имеется ли в записи натурального числа ноль. Язык
программирования паскаль. 0
        0
         0
        0
    Ответы на вопрос
 
        var a,b,c:integer;
begin
b:=0;
readln(a);
if a<10 then
begin
if a*5=0 then b:=1;
end;
if (a>=10) and (a<100) then
begin
if ((a div 10)*5=0) then b:=1;
if ((a mod 10)*5=0) then b:=1;
end;
if (a>=100) and (a<1000) then
begin
if ((a div 100)*5=0) then b:=1;
if (((a div 10) mod 10)*5=0)then b:=1;
if ((a mod 10)*5=0)then b:=1;
end;
if b=1 then writeln('yes') else writeln('no');
end.
 0
                    0
                     0
                    0
                 
            Для проверки наличия нуля в записи натурального числа в языке программирования Паскаль, можно написать следующую программу:
```pascal program CheckZero; var num: integer; hasZero: boolean; begin writeln('Введите натуральное число:'); readln(num); hasZero := False; while num > 0 do begin if num mod 10 = 0 then begin hasZero := True; break; end; num := num div 10; end; if hasZero then writeln('В записи числа есть ноль.') else writeln('В записи числа нет нуля.'); end. ```
Эта программа запрашивает у пользователя натуральное число, а затем проверяет каждую цифру числа на равенство нулю. Если в записи числа найден ноль, программа выводит сообщение "В записи числа есть ноль", иначе выводится сообщение "В записи числа нет нуля".
Примечание: В данной программе предполагается, что пользователь вводит только натуральные числа. Если требуется обработка отрицательных чисел или чисел с десятичной частью, то код программы нужно будет изменить соответствующим образом.
Надеюсь, это поможет! Если у вас возникнут еще вопросы, не стесняйтесь задавать.
 0
                    0
                     0
                    0
                Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			