1. Составить программу ,которая определяет ,сколько раз в предложении встречается слово "дом". 2.
Составить программу ,вычисляющую длину самого короткого слова в предложении из трёх слов ,разделённых пробелами. ПаскальОтветы на вопрос
Var S:string;
i,k:integer;
Begin
Write('Введите строку: ');ReadLn(S);
LowerCase(S);
k:=0;
For i:= 1 to S.Length-2 do
if S[i] = 'д' then
if S[i+1] = 'о' then
if S[i+2] = 'м' then
k:=k+1;
WriteLn(k)
End.
Var
S:string;
i,d1,d2,d3:integer;
Begin
WriteLn('Введите строку:');
ReadLn(S);
i:=0;
Repeat
i+=1
Until S[i] = ' ';
d1:=i-1;
Repeat
i+=1
Until S[i] = ' ';
d2:=i-d1-2;
Repeat
i+=1
Until i = S.Length;
d3:=i-d2-d1-2;
if d3 < d1 then d1:=d3;
if d2 < d1 then d1:=d2;
WriteLn(d1)
End.
Программа для подсчета количества слов "дом" в предложении
```pascal program CountWord; uses crt;
var sentence: string; count: integer; i: integer;
begin clrscr; writeln('Введите предложение:'); readln(sentence);
count := 0; for i := 1 to length(sentence) do begin if (sentence[i] = 'д') and (sentence[i+1] = 'о') and (sentence[i+2] = 'м') then count := count + 1; end;
writeln('Слово "дом" встречается в предложении ', count, ' раз(а).'); readln; end. ```
Программа для вычисления длины самого короткого слова в предложении
```pascal program ShortestWordLength; uses crt;
var sentence: string; shortestLength: integer; word: string; i: integer;
begin clrscr; writeln('Введите предложение из трех слов, разделенных пробелами:'); readln(sentence);
shortestLength := length(sentence); word := '';
for i := 1 to length(sentence) do begin if sentence[i] <> ' ' then word := word + sentence[i] else begin if length(word) < shortestLength then shortestLength := length(word); word := ''; end; end;
if length(word) < shortestLength then shortestLength := length(word);
writeln('Длина самого короткого слова в предложении: ', shortestLength); readln; end. ```
Обратите внимание, что в обоих программах предполагается, что предложение вводится пользователем с клавиатуры. Если вам нужно ввести предложение напрямую в коде программы, вы можете удалить строки `writeln('Введите предложение:');` и `readln(sentence);` в первой программе, а также строки `writeln('Введите предложение из трех слов, разделенных пробелами:');` и `readln(sentence);` во второй программе.
Примечание: Предоставленный код является примером и может потребовать доработки в зависимости от требований вашей задачи.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
