Вопрос задан 11.01.2020 в 11:54. Предмет Информатика. Спрашивает Геворкян Родион.

Циклы (for and while), помогите составить программу в Pascal ABC, пожалуйста.Составьте программу,

которая выводит на экран количество трехзначных чисел у которых вторая цифра в два раза больше первой, а третья в два раза больше второй.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Фомичёв Денис.
Var
n, k: integer;
t, v, p : real;
begin
    k:=0;
    for n := 100 to 999 do
    begin
        p:= n div 100;
        v := (n div 10)mod 10;
        t := n mod 10;
        if (v = 2*p) and (t = 2*v) then
            k:=k+1   ;
      end;
      print(k);
end.
   


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на языке Pascal ABC, которая выводит на экран количество трехзначных чисел, у которых вторая цифра в два раза больше первой, а третья в два раза больше второй:

```pascal program CountNumbers; var number, count: integer; begin count := 0; // инициализируем счетчик нулем // перебираем все трехзначные числа for number := 100 to 999 do begin // проверяем условие if (number mod 100) div 10 = 2 * ((number mod 1000) div 100) then count := count + 1; // увеличиваем счетчик, если условие выполняется end; // выводим результат writeln('Количество трехзначных чисел: ', count); end. ```

Программа использует цикл `for` для перебора всех трехзначных чисел от 100 до 999. Внутри цикла проверяется условие: вторая цифра числа равна двукратному значению первой цифры, а третья цифра равна двукратному значению второй цифры. Если условие выполняется, счетчик `count` увеличивается на 1. По завершении цикла выводится количество чисел, удовлетворяющих условию.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос