
На вход программе подаются целые числа x и y,необходимо уменьшить на 100 то число которое является
трехзначным.И увеличить в 10 раз то число которое является меньше ста

Ответы на вопрос

function thg(var t: real): boolean;
begin
thg:=false;
if (t>=100) and(t<1000) then thg:= true;
end;
var x,y: real;
begin
readln(x,y);
if thg(x) then x:=x-100;
if thg(y) then y:=y-100;
if x<100 then x:=x*10;
if y<100 then y:=y*10;
writeln(x,' ',y);
end.



Конечно, давайте рассмотрим, как можно реализовать данную задачу на языке программирования. Например, давайте используем псевдокод для лучшего понимания алгоритма:
1. Считать значения x и y. 2. Проверить, является ли x трехзначным числом (от 100 до 999). - Если да, уменьшить x на 100. - Если нет, оставить x без изменений. 3. Проверить, является ли y числом, меньшим ста. - Если да, увеличить y в 10 раз. - Если нет, оставить y без изменений. 4. Вывести результаты x и y.
Пример на псевдокоде:
```plaintext Считать x Считать y
Если x в пределах от 100 до 999, то x = x - 100 Иначе оставить x без изменений
Если y меньше 100, то y = y * 10 Иначе оставить y без изменений
Вывести x и y ```
Если вы предпочитаете использовать определенный язык программирования, дайте мне знать, и я могу предоставить пример кода для этого языка.


Топ вопросов за вчера в категории Информатика








Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili