Паскаль.Помогите кто знает. Нужно найти количество минимальных значений массива
Ответы на вопрос
const n=20;
var a:array[1..n] of integer;
i,min,k: integer;
begin
randomize;
for i:=1 to n do
begin
a[i]:=random(10);
write(a[i]:3);
end;
writeln;
min:=a[1];
k:=1;
for i:=2 to n do
if a[i]<min then
begin
min:=a[i]; k:=1;
end
else if a[i]=min then k:=k+1;
writeln('min = ', min,' = ',k);
end.
Пример:
6 2 7 2 3 0 1 6 0 6 0 5 0 4 5 9 1 6 0 7
min = 0 = 5
program massiv;
var a: array[1..10] of integer;
var min,k,i:integer;
begin
writeln('Введите массив');
min:=9999;
k:=0;
for i:=1 to 10 do
begin
readln(a[i]);
end;
for i:=1 to 10 do
begin
if a[i]<min then
begin
min:=a[i];
end;
end;
for i:=1 to 10 do
begin
if a[i]=min then
begin
k:=k+1;//считаем минимальные элементы
end;
end;
writeln ('Здесь ',k,' элементов с минимальным значением ',min);
end.
Конечно, я готов помочь! Для нахождения количества минимальных значений в массиве на языке программирования Pascal, вам нужно выполнить следующие шаги:
1. Определите массив. 2. Найдите минимальное значение в массиве. 3. Пройдитесь по массиву и подсчитайте количество элементов, равных минимальному значению.
Пример кода на Pascal может выглядеть так:
```pascal program CountMinValues;
const N = 10; // Размер массива
var arr: array[1..N] of Integer; // Объявление массива i, minValue, countMinValues: Integer;
begin // Ввод элементов массива writeln('Введите элементы массива:'); for i := 1 to N do begin write('arr[', i, ']: '); readln(arr[i]); end;
// Находим минимальное значение в массиве minValue := arr[1]; // Предполагаем, что первый элемент минимальный for i := 2 to N do begin if arr[i] < minValue then minValue := arr[i]; end;
// Подсчитываем количество минимальных значений countMinValues := 0; for i := 1 to N do begin if arr[i] = minValue then Inc(countMinValues); end;
// Вывод результата writeln('Минимальное значение в массиве: ', minValue); writeln('Количество минимальных значений: ', countMinValues);
readln; end. ```
Этот код создает массив, заполняет его значениями, находит минимальное значение и подсчитывает количество элементов, равных минимальному значению. Обратите внимание, что в этом примере размер массива задан как константа `N`, и его можно изменить в зависимости от ваших потребностей.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
