Написать программу на Pacal ABC и составить блок-схему этой программы.Задание: проверить истинность
высказывания: "Все цифры данного трехзначного числа различны"Программа должна выводить либо True либо False. (с помощью типа: boolean) Зараннее спасибо!Ответы на вопрос
uses crt;
var
x:integer;
y:boolean;
begin
clrscr;
write('Введите трехзначное число'); read(x);
y:=((x mod 10)<>(x div 100))and
((x div 100)<>(x mod 100 div 10))and
((x mod 10)<>(x mod 100 div 10));
write(y);
end.
Программа на Pascal ABC, которая проверяет истинность высказывания "Все цифры данного трехзначного числа различны" и выводит либо True, либо False:
```pascal program CheckDigits; var number: integer; digit1, digit2, digit3: integer; isDifferent: boolean; begin writeln('Введите трехзначное число:'); readln(number);
digit1 := number div 100; // Получаем первую цифру числа digit2 := (number div 10) mod 10; // Получаем вторую цифру числа digit3 := number mod 10; // Получаем третью цифру числа
isDifferent := (digit1 <> digit2) and (digit1 <> digit3) and (digit2 <> digit3);
writeln('Все цифры данного трехзначного числа различны: ', isDifferent); end. ```
Блок-схема программы:
``` ┌───────┐ ┌───────────┐ ┌───────────┐ ┌───────────┐ │ Ввод │────────▶│ Получить │────────▶│ Получить │────────▶│ Получить │ │ числа │ │ первую │ │ вторую │ │ третью │ └───────┘ │ цифру │ │ цифру │ │ цифру │ └───────────┘ └───────────┘ └───────────┘ │ │ │ ▼ ▼ ▼ ┌───────────┐ ┌───────────┐ ┌───────────┐ │ Проверить │ │ Проверить │ │ Проверить │ │ различие │ │ различие │ │ различие │ │ цифр │ │ цифр │ │ цифр │ └───────────┘ └───────────┘ └───────────┘ │ │ │ ▼ ▼ ▼ ┌───────────┐ ┌───────────┐ ┌───────────┐ │ Вывести │ │ Вывести │ │ Вывести │ │ результат │ │ результат │ │ результат │ └───────────┘ └───────────┘ └───────────┘ ```
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
