ЯЗЫК ПРОГРАММИРОВАНИЯ C++. Даны два натуральных числа A и B. Написать программу которая позволит
высеслить остаток от деления A и B, увеличеный в 10 раз.Пример Ввод:46 13Вывод:70Ответы на вопрос
Вот код:
#include<iostream>
using namespace std;
int main ()
{
int a, b, c;
cin>>a>>b;
c=a%b;
cout<<c*10;
cin.get();
return 0;
}
Для решения данной задачи на языке программирования C++ можно использовать оператор % (остаток от деления) и оператор * (умножение).
Ниже приведен код программы:
```cpp
#include
int main() { int A, B; cout << "Введите два натуральных числа A и B: "; cin >> A >> B;
int result = (A % B + 1) * 10; cout << "Остаток от деления A на B, увеличенный в 10 раз: " << result << endl;
return 0; } ```
В данной программе мы сначала объявляем две переменные типа int - A и B, которые будут хранить введенные пользователем значения. Затем с помощью оператора cin мы просим пользователя ввести два натуральных числа A и B.
Далее мы используем оператор % для вычисления остатка от деления A на B. Затем к полученному остатку прибавляем 1 и умножаем на 10, чтобы увеличить результат в 10 раз.
Наконец, мы выводим полученный результат с помощью оператора cout.
После выполнения программы, она будет ожидать ввода двух натуральных чисел A и B. В нашем примере, если ввести A = 46 и B = 13, то программа выведет "Остаток от деления A на B, увеличенный в 10 раз: 70".
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
