Вопрос задан 09.01.2020 в 12:23. Предмет Информатика. Спрашивает Фабрицкий Данил.

1)Составьте программу на языке Pascal, в которой пользователь вводит с клавиатуры значения

элементов массива, а программа выводит значения элементов массива с противоположным знаком. 2)Составьте программу на языке Pascal, в которой пользователь вводит с клавиатуры значения элементов массива, а программа выводит значения первой половины элементов увеличенных в 2 раза, а второй половины элементом уменьшенных в 2 раза.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Нагаева Самира.
1)

var
mas: array [1..10] of integer;
i:integer;
begin
for i:=1 to 10 do
read(mas[i]);
for i:=1 to 10 do begin
if mas[i]<0 then
write(abs(mas[i]),' ')
else
write(-mas[i],' ');
end;
end.

2)

var
mas: array [1..10] of real;
i:integer;
begin
for i:=1 to 10 do
read(mas[i]);
for i:=1 to 5 do
write(mas[i]*2,' ');
for i:=6 to 10 do
write(mas[i]/2,' ');
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа на языке Pascal для вывода элементов массива с противоположным знаком

```pascal program ReverseArray;

const MAX_SIZE = 100;

type IntArray = array[1..MAX_SIZE] of Integer;

var arr: IntArray; n, i: Integer;

begin Write('Введите размер массива (не более ', MAX_SIZE, '): '); ReadLn(n);

WriteLn('Введите элементы массива:'); for i := 1 to n do begin Write('arr[', i, '] = '); ReadLn(arr[i]); end;

WriteLn('Массив с противоположным знаком:'); for i := 1 to n do WriteLn('arr[', i, '] = ', -arr[i]);

ReadLn; // Чтобы консольное окно не закрывалось сразу end. ```

Программа на языке Pascal для вывода элементов массива с измененными значениями

```pascal program ModifyArray;

const MAX_SIZE = 100;

type RealArray = array[1..MAX_SIZE] of Real;

var arr: RealArray; n, i: Integer;

begin Write('Введите размер массива (не более ', MAX_SIZE, '): '); ReadLn(n);

WriteLn('Введите элементы массива:'); for i := 1 to n do begin Write('arr[', i, '] = '); ReadLn(arr[i]); end;

WriteLn('Массив с измененными значениями:'); for i := 1 to n do begin if i <= n div 2 then arr[i] := arr[i] * 2 else arr[i] := arr[i] / 2;

WriteLn('arr[', i, '] = ', arr[i]); end;

ReadLn; // Чтобы консольное окно не закрывалось сразу end. ```

В обоих программах пользователю предлагается ввести размер массива и значения его элементов. Затем программа выводит соответствующие значения массива с противоположным знаком или измененными значениями в зависимости от задания. Программы написаны на языке Pascal.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос