
Вопрос задан 08.01.2020 в 08:19.
Предмет Информатика.
Спрашивает Савенков Руслан.
Составьте программу, которая определяет к какой группе относится введенный символ (с) – к цифрам,
заглавным или прописным буквам. На экран должна выводиться фраза «Символ с – это …», где вместо … пишется соответствующая группа (например, «Символ R – это заглавная буква»).

Ответы на вопрос

Отвечает Бутчик Вася.
// PascalABC.NET 3.0, сборка 1157 от 02.02.2016
begin
var c:=ReadlnChar('Введите символ');
case c of
'A'..'Z': Writeln('Символ ',c,'- это прописная латинская буква');
'a'..'z': Writeln('Символ ',c,'- это строчная латинская буква');
'А'..'Я','Ё': Writeln('Символ ',c,'- это прописная русская буква');
'а'..'я','ё': Writeln('Символ ',c,'- это строчная русская буква');
'0'..'9': Writeln('Символ ',c,'- это цифра');
else Writeln('Символ ',c,'- это специальный знак')
end
end.
begin
var c:=ReadlnChar('Введите символ');
case c of
'A'..'Z': Writeln('Символ ',c,'- это прописная латинская буква');
'a'..'z': Writeln('Символ ',c,'- это строчная латинская буква');
'А'..'Я','Ё': Writeln('Символ ',c,'- это прописная русская буква');
'а'..'я','ё': Writeln('Символ ',c,'- это строчная русская буква');
'0'..'9': Writeln('Символ ',c,'- это цифра');
else Writeln('Символ ',c,'- это специальный знак')
end
end.


Топ вопросов за вчера в категории Информатика

Информатика 562

Информатика 404

Информатика 31

Информатика 76

Информатика 16

Информатика 41

Информатика 31
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili