Вопрос задан 04.01.2020 в 03:59.
Предмет Информатика.
Спрашивает Маркаланина Анастасия.
Нужно написать программу в Pascal по теме: ТАБУЛИРОВАНИЕ ФУНКЦИИ С ПОМОЩЬЮ ОПЕРАТОРА ЦИКЛА С
ПАРАМЕТРОМ.
Ответы на вопрос
Отвечает Маринченко Кристина.
PascalABC.NET 3.4.2, сборка 1884 от 24.11.2018
Внимание! Если программа не работает, обновите версию!
begin
var (a, b, xнач, шаг, xкон) := (-5.0, 12.0, -2.0, 0.2, 2.0);
var z: real;
for var i := 0 to Trunc((xкон - xнач) / шаг) do
begin
var x := xнач + i * шаг;
if x <= -Pi / 2 then z := 2 * Sin(x)
else
if x < Pi / 2 then z := a * Sin(x) + B
else z := Cos(x);
Writeln(x:20:15, z:20:15)
end
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
