
Вопрос задан 04.07.2019 в 20:29.
Предмет Информатика.
Спрашивает Каюмов Тимур.
Дана программа, написанная на языке Pascal, формирующая квадратный массив и заполняющая его по
определённым правилам. Чему будет равно значение переменной Р по окончании выполнения программы? const N=7; var i, К:integer; R, P:real; A:array[1..N,1..N] of real; beginK:=0; R:=0; while K<N dobeginfor i:=1 to N-K dobegin R:=R+1; A[i,i+K]:= R; end;K:= K+1;end;P:= A[3,7]; writeln(P);end.А) 17 Б) 22 В) 25 Г) 28

Ответы на вопрос

Отвечает Тесёлкина Анна.
1. После первого begin добавьте перевод строки. Иначе программа работать не будет.
2. Результат P = 25
Ответ: вариант В
2. Результат P = 25
Ответ: вариант В


Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili