Вопрос задан 03.07.2019 в 05:13.
Предмет Информатика.
Спрашивает Галиуллина Ильдана.
Напишите программу, которая инвертирует определенный бит в заданном числе (биты при этом нумеруются
с 0, начиная с младших).Ответы на вопрос
Отвечает Гайнуллина Сагдана.
Var
n,k:integer;
begin
Write('Укажите число и номер инвертируемого бита: ');
Read(n,k);
Writeln('Результат: ',n xor (1 shl k))
end.
Тестовое решение:
Укажите число и номер инвертируемого бита: 573 4
Результат: 557
n,k:integer;
begin
Write('Укажите число и номер инвертируемого бита: ');
Read(n,k);
Writeln('Результат: ',n xor (1 shl k))
end.
Тестовое решение:
Укажите число и номер инвертируемого бита: 573 4
Результат: 557
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 19
Информатика 266
Информатика 34
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
