
Вопрос задан 30.06.2019 в 13:46.
Предмет Информатика.
Спрашивает Каракулова Наташа.
Написать программу в PascalABC.net Удалить из строчки S символы + - * А потом заменить все символы
на символы следующие по алфавиту.

Ответы на вопрос

Отвечает Шевченко Вова.
// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString('Введите строку:');
s:=s.RegexReplace('[\+\-\*]',''); // удалили
s:=s.Select(c->Chr(Ord(c)+1)).JoinIntoString(''); // заменили
Writeln(s)
end.
Пример:
Введите строку: Мой пример: 23+18.4*(3.1-0.15)=52.7 Is it true?
Нпк!рсйнжс;!3429/5)4/21/26*>63/[email protected]
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString('Введите строку:');
s:=s.RegexReplace('[\+\-\*]',''); // удалили
s:=s.Select(c->Chr(Ord(c)+1)).JoinIntoString(''); // заменили
Writeln(s)
end.
Пример:
Введите строку: Мой пример: 23+18.4*(3.1-0.15)=52.7 Is it true?
Нпк!рсйнжс;!3429/5)4/21/26*>63/[email protected]


Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili