Вопрос задан 26.06.2019 в 21:06. Предмет Информатика. Спрашивает Бутчик Вася.

Напишите программу в паскаль! Натуральное число называется числом Армстронга, если сумма цифр

числа, возведенных в K -ю степень (где K – количество цифр в числе) равна самому числу. Например, 153 = 1 3 + 5 3 + 3 3 . Напишите программу, которая находит все числа Армстронга на отрезке [ a , b ] . Входные данные Входная строка содержит два натуральных числа – значения a и b , разделённых пробелами. Гарантируется, что a ≤ b . Выходные данные Программа должна вывести в одну строчку все числа Армстронга на отрезке [ a , b ] , разделив их пробелами. Если таких чисел нет, программа должна вывести число -1.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Анцупов Артём.
Program Amstrong;
var
  a,b: integer;
  i,j,k,
  ci,
  si,mi,
  errkod: integer;
  sti: string;
  flag: Boolean;
begin
  Readln(a,b);
  flag:=false;
  for i:=a to b do
  begin
    str(i, sti);
    si:=0;
    for j:=1 to Length(sti) do
    begin
      val(sti[j],mi,errkod);
      ci:=1;
      for k:=1 to Length(sti) do
        ci:=ci*mi;
      si:=si+ci;
    end;
    if si=i then
    begin
      write(si,' ');
      flag:=true
    end;
  end;
  if not flag then write(-1);
  Readln;
 end.


0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос