
Вопрос задан 23.05.2018 в 07:50.
Предмет Информатика.
Спрашивает Чаленко Вика.
ПОМОГИТЕ ИСПРАВИТЬ КОД, ЯЗЫК СИ Напишите программу поиска максимального из четырех чисел с
использованием функции поиска большего из двух.


Ответы на вопрос

Отвечает Классен Сергей.
#include <stdio.h>
int chislo(int a, int b) { if ( a > b ) return a; else return b;}
int main(){ int a,b,c,d;
printf("\n Óñëîâèå: Íàïèøèòå ïðîãðàììó ïîèñêà ìàêñèìàëüíîãî èç ÷åòûðåõ ÷èñåë ñ èñïîëüçîâàíèåì ôóíêöèè ïîèñêà áîëüøåãî èç äâóõ."); printf("\n\t Ââåäèòå 1 ÷èñëî -> "); scanf("%i",&a); printf("\n\t Ââåäèòå 2 ÷èñëî -> "); scanf("%i",&b); printf("\n\t Ââåäèòå 3 ÷èñëî -> "); scanf("%i",&c); printf("\n\t Ââåäèòå 4 ÷èñëî -> "); scanf("%i",&d);
printf ( "max=%i\n" , chislo(chislo(chislo(a,b),c),d));
return 0;}


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili