Вопрос задан 18.06.2019 в 17:56.
Предмет Информатика.
Спрашивает Харьковский Андрей.
Напишите программу, которая заполняет массив квадратами натуральных чисел от 1 до N . Входные
данные Входная строка содержит размер массива N . Гарантируется, что 0 < N ≤ 10000 . Выходные данные Программа должна вывести содержимое массива: квадраты N первых натуральных чисел. Пример входных данных 5 Результат работы программы 1 4 9 16 25 Пример входных данных 2 Результат работы программы 1 4 С++Ответы на вопрос
Отвечает Урванцева Ярослава.
#include <iostream>
using namespace std;
int main()
{
int n;
cout<<"enter n: "<<endl;
cin>>n;
if (n>0 && n<=10000)
{
int a[n];
int c=1;
a[0]=1;
for(int i=1;i<n;i++)
{
c=c+1;
a[i]=c*c;
}
for(int i=0; i<n ;i++ )
{
cout<<a[i]<<" ";
}
}
return 0;
}
using namespace std;
int main()
{
int n;
cout<<"enter n: "<<endl;
cin>>n;
if (n>0 && n<=10000)
{
int a[n];
int c=1;
a[0]=1;
for(int i=1;i<n;i++)
{
c=c+1;
a[i]=c*c;
}
for(int i=0; i<n ;i++ )
{
cout<<a[i]<<" ";
}
}
return 0;
}
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
