Вопрос задан 17.06.2019 в 15:14.
Предмет Информатика.
Спрашивает Рыбин Никита.
Помогите написать решение Паскаль в ALGO. Задание 1) Для заданного X вычислить значение функций:Y=
1) корень из X в квадрате, если x=2 2) "нет решений", если x=0 3) 3x в квадрате минус 5, если X=3,4,5,6.Задание 2) - Составить алгоритм и программу Написать программу, которая определяет по последней цифре числа последнюю цифру его квадрата. Прошу написать полное решение программы, Спасибо ЗаранееОтветы на вопрос
Отвечает Михайлова Зоя.
1)
Var x:integer;
Begin
write('x=');
readln(x);
if x=2 then writeln('y=',sqrt(x*x))
else
if (x>=3)and(x<=6) then writeln('y=',(3*x*x-5))
else writeln('Решений нет');
End.
2)
Var x:integer;
Begin
write('x=');
readln(x);
x:=x mod 10;
writeln('Последняя цифра квадрата числа: ',x*x);
End.
Var x:integer;
Begin
write('x=');
readln(x);
if x=2 then writeln('y=',sqrt(x*x))
else
if (x>=3)and(x<=6) then writeln('y=',(3*x*x-5))
else writeln('Решений нет');
End.
2)
Var x:integer;
Begin
write('x=');
readln(x);
x:=x mod 10;
writeln('Последняя цифра квадрата числа: ',x*x);
End.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
