Вопрос задан 12.06.2019 в 07:31. Предмет Информатика. Спрашивает Тимофеев Никита.

Напишите программу для заштрихованной области графика на языке Pascal var x,y: real; begin read

(x,y); if .........
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Казимова Надежда.
Var
  x,y:real;
  b:boolean;
begin
  read(x,y);
  if sqr(x)+sqr(y)<=1 then
    if x<=0 then b:=((y>=0) and (y<=-x) or (y<=x))
    else b:=((y<=0) and(y>=-x) or (y>=x))
  else b:=False;
  if b then Writeln('Точка попадает в область или лежит на границе')
  else Writeln('Точка не попадает в область и не лежит на границе')
end.

0 0

Последние заданные вопросы в категории Информатика

Задать вопрос