1. Составьте программу в Pascal ABC. Даны три числа. Найти сумму двух наибольших из них. 2.
Составьте программу в Pascal ABC. Для данного вещественного x найти значение следующей функции f, принимающей вещественные значения:f(x)=(2-х)/x2,если x>0, иначе f(x)=6-х3 3. Составьте программу в Pascal ABC. Даны два числа. Найти их сумму, разность и произведение.Ответы на вопрос
1 задача.
var a, b, c: integer;
begin
write('Введите через пробел три числа: ');
readln(a, b, c);
if (a > b) then
if (b > c) then
write('Сумма двух наибольших чисел: ', a + b)
else
write('Сумма двух наибольших чисел: ', a + c)
else
if (c > a) then
write('Сумма двух наибольших чисел: ', c + b)
else
write('Сумма двух наибольших чисел: ', b + a)
end.
2 задача.
var x, f: real;
begin
write('Введите значение x: ');
readln(x);
if (x > 0) then
f := (2 - x) / (x * x)
else
f := 6 - (x * x * x);
writeln('Значение функции при данном x: ', f)
end.
3 задача.
var a, b: integer;
write('Введите через пробел два числа: ');
readln(a, b);
writeln('Сумма чисел: ', a + b);
writeln('Разность чисел: ', a - b);
writeln('Произведение чисел: ', a * b)
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
