Вопрос задан 06.06.2019 в 20:50.
Предмет Информатика.
Спрашивает Гончарова Катя.
Составьте программу вычисления суммы цифр трёхзначного числа а. значение а введите с клавиатуры.
Ответы на вопрос
Отвечает Сёмина Ульяна.
Program summa_4isel;
Uses crt;
Var a,e,z,y,x:integer;
Begin
Writeln('Введите трехзначное число число');
Readln(a);
x:=a div 100;
y:=(a-x*100) div 10;
z:=a-y*10-x*100;
e:=x+y+z;
writeln('Сумма чисел ',x,' ',y,' и ',z,' равна ',e,'.');
end.
Uses crt;
Var a,e,z,y,x:integer;
Begin
Writeln('Введите трехзначное число число');
Readln(a);
x:=a div 100;
y:=(a-x*100) div 10;
z:=a-y*10-x*100;
e:=x+y+z;
writeln('Сумма чисел ',x,' ',y,' и ',z,' равна ',e,'.');
end.
Топ вопросов за вчера в категории Информатика
Информатика 22
Информатика 36
Информатика 60
Информатика 2166
Информатика 10
Информатика 571
Информатика 49
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
