Даны целые числа x и y. Написать программу определения знака разности x-y. Разность вычислять
нельзя. Разрешается сравнивать числа x и y с нулем, а между собой можно сравнивать только абсолютные величины чисел x и y.Ответы на вопрос
Program raznost_xy;
var x, y:integer;
begin
write ('Введите число х = ');
readln (x);
write ('Введите число у = ');
readln (y);
if (x>0) and (y>0) then
begin
if abs(x)>abs(y) then write ('x-y > 0');
if abs(x)=abs(y) then write ('x-y = 0');
if abs(x)<abs(y) then write ('x-y < 0');
end;
if (x<0) and (y<0) then
begin
if abs(x)>abs(y) then write ('x-y < 0');
if abs(x)=abs(y) then write ('x-y = 0');
if abs(x)<abs(y) then write ('x-y > 0');
end;
if (x=0) and (y=0) then write ('x-y = 0');
if (x>0) and (y<0) then write ('x-y > 0');
if (x<0) and (y>0) then write ('x-y < 0');
if (x=0) and (y>0) then write ('x-y < 0');
if (x=0) and (y<0) then write ('x-y > 0');
if (x>0) and (y=0) then write ('x-y > 0');
if (x<0) and (y=0) then write ('x-y < 0');
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
