Вопрос задан 02.06.2019 в 16:59. Предмет Информатика. Спрашивает Кондрашов Дима.

Напишите программу выводящую индекс наименьшего числа 3 9 1 3 5 8 5 3 6 7 6 5 4 6 1 81

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Кострикова Вика.
// PascalABC.NET 3.3, сборка 1583 от 25.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=Arr(3,9,1,3,5,8,5,3,6,7,6,5,4,6,1,81); a.Println;
  a.IndexesOf(t->t=a.Min).Select(t->t+1).Println
end.

Результат
3 9 1 3 5 8 5 3 6 7 6 5 4 6 1 81
3 15
0 0
Отвечает Франчук Алина.

var i,n,k,min:integer;
a:array[1..1000] of integer;
begin
 write('Write size array: '); readln(n);

 for i:=1 to n do
   read(a[i]);
 min:=a[1];
 for i:=1 to n do
  if min>a[i]
    then begin min:=a[i]; k:=i; end;
 writeln(k);
end.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос