Вопрос задан 19.05.2018 в 06:10.
Предмет Информатика.
Спрашивает Tumanov Kostya.
Составьте программу вычисления суммы элементов массива от второго положительного и до конца Я
составил такой код, но вот только сумму он определяет не так. Есть какие-то идеи? program qq; const N=10; var a:array[1..N] of integer; i,p,j,sum:integer; begin for i:=1 to N do begin a[i]:=random(20)-10; write(a[i],' '); end; j:=0; for i:=1 to N do begin if a[i]>0 then j:=j+1; if j = 2 then p:=i; end; for i:=p+1 to N do sum:=sum+a[i]; writeln(); writeln('Сумма элементов от второго положительного: ',sum); end.Ответы на вопрос
Отвечает Першичева Полина.
У вас что-то слишком сложная структура для такой задачи.
Предлагаю вариант покороче, скрин и исходник в приложении.
Складывает все числа (положительные и отрицательные) начиная со второго положительного включительно, то есть второй элемент так же будет задействован.

Топ вопросов за вчера в категории Информатика
Информатика 75
Информатика 37
Информатика 11
Информатика 41
Информатика 22
Информатика 268
Информатика 36
Информатика 30
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
