Вопрос задан 22.05.2019 в 04:34.
Предмет Информатика.
Спрашивает Федів Антон.
Помогите составить программу с помощью цикла repeat. составить программу выводящую и суммирующую
любое количество целых чисел если введено 999 о на экран выводится результат суммирования.Ответы на вопрос
Отвечает Пушин Кирилл.
На языке Java. Программа складывает и отрицательные и положительные числа.
class SumNum{
public static void main(String args[]){
try{
long sumNum=0,numSum=new Long(new java.io.BufferedReader(new java.io.InputStreamReader(System.in)).readLine());
do sumNum+=numSum;while((numSum>0?--numSum:++numSum)!=0);System.out.print("Результат "+sumNum);
}catch(java.io.IOException io){
System.out.println(" - Ошибка ввода!\n"); main(null);
}catch(NumberFormatException nf){
System.out.println(" - Введите целочисленное значение!\n"); main(null);
}
}
}
class SumNum{
public static void main(String args[]){
try{
long sumNum=0,numSum=new Long(new java.io.BufferedReader(new java.io.InputStreamReader(System.in)).readLine());
do sumNum+=numSum;while((numSum>0?--numSum:++numSum)!=0);System.out.print("Результат "+sumNum);
}catch(java.io.IOException io){
System.out.println(" - Ошибка ввода!\n"); main(null);
}catch(NumberFormatException nf){
System.out.println(" - Введите целочисленное значение!\n"); main(null);
}
}
}
Топ вопросов за вчера в категории Информатика
Информатика 16
Информатика 13
Информатика 39
Информатика 160
Информатика 65
Информатика 44
Информатика 84
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
