Вопрос задан 17.05.2018 в 03:55. Предмет Информатика. Спрашивает Гимаева Лиля.

Написать программу в которой. Даны 3 положительных числа и определить можно ли построить

треугольник со сторонами , длинны которых равны этим числам и является ли этот треугольник прямоугольным
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Писарева Софья.

#include<iostream>
using namespace std;
int main() {
int a,b,c;
cin >> a >> b >> c;
if ((a+b>c)&(a+c>b)&(c+b>a)) {
if (a*a+b*b=c*c)||(b*b+c*c=a*a)||(c*c+a*a=b*b)
cout << "треугольник прямоугольный";
else cout << "треугольник не прямоугольный";
}
else cout << "их данных сторон невозможно сделать треугольник";
return 0;
}

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос