
Вопрос задан 18.05.2019 в 03:08.
Предмет Информатика.
Спрашивает Жақсыбек Алимжан.
Напишите программу, которая обнуляет все элементы квадратной матрицы, расположенные выше главной
диагонали. Входные данные В первой строке записаны через пробел размер квадратной матрицы N (количество строк равно количеству столбцов) ( 1 ≤ N ≤ 100 ). В следующих N строках записаны строки матрицы, в каждой – по N натуральных чисел, разделённых пробелами. Выходные данные Программа должна вывести матрицу, у которой все элементы выше главной диагонали нулевые, а остальные элементы такие же, как в исходной матрице.

Ответы на вопрос

Отвечает Руднева Анастасия.
Program obnulenie;
var a:array[1..100,1..100] of integer;
i,j,n:integer;
begin
writeln('Введите размер квадратной матрицы:');
readln(n);
writeln('Введите матрицу:');
for i:=1 to n do
for j:=1 to n do
begin
read(a[i,j]);
if j>i then a[i,j]:=0;
end;
writeln('Измененная матрица:');
for i:=1 to n do
begin
for j:=1 to n do
write(a[i,j],' ');
writeln;
end;
end.
var a:array[1..100,1..100] of integer;
i,j,n:integer;
begin
writeln('Введите размер квадратной матрицы:');
readln(n);
writeln('Введите матрицу:');
for i:=1 to n do
for j:=1 to n do
begin
read(a[i,j]);
if j>i then a[i,j]:=0;
end;
writeln('Измененная матрица:');
for i:=1 to n do
begin
for j:=1 to n do
write(a[i,j],' ');
writeln;
end;
end.


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili