Вопрос задан 16.05.2018 в 15:01.
Предмет Информатика.
Спрашивает Комиссарова Надежда.
В PascalABC Напишите программу, которая выводит все простые числа в диапазоне от K до N ( 2 ≤ K ≤ N
≤ 100000 ), у которых первая и последняя цифры десятичной записи одинаковые. Входные данные Входная строка содержит два натуральных числа, разделённые пробелом, K и N ( 2 ≤ K ≤ N ≤ 100000 ). Выходные данные Программа должна вывести все простые числа, у которых одинаковые первая и последняя цифры десятичной записи, в диапазоне от K до N в одну строку, разделив их пробелами. Если таких чисел нет, нужно вывести число 0. Примеры входные данные 100 200 выходные данные 101 131 151 181 191 входные данные 20 30 выходные данные 0Ответы на вопрос
Отвечает Шубинцев Богдан.
Program n1;
var k,n,i: longint;
co: byte;
function simply(a: longint ):boolean;
var i: longint;
begin
simply:=true;
for i:=2 to trunc(sqrt(a)) do begin if a mod i=0 then begin
simply:=false;
break
end
end
end;
function cr(a: longint): boolean;
var n: longint;
begin
n:=a;
cr:=false;
repeat
n:=n div 10;
until n mod 10 =n;
if n=(a mod 10) then
begin
cr:=true;
end;
end;
begin
readln(k,n);
for i:=k to n do if simply(i) then begin if (i=2) or (i=3) or (i=5) or (i=7) or cr(i) then
begin
write(i,' ');
co:=1;
end
end;
if co=0 then write(0);
end.
Топ вопросов за вчера в категории Информатика
Информатика 16
Информатика 13
Информатика 39
Информатика 160
Информатика 65
Информатика 44
Информатика 84
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
