Вопрос задан 17.05.2019 в 13:44.
Предмет Информатика.
Спрашивает Ляхман Богдан.
В массиве хранится информация о среднедневной температуре за неделю в декабре. Составьте программу,
которая подсчитает, сколько дней за неделю было с положительной температурой, сколько дней было с отрицательной и нулевой температурой. Найдите максимальную температуру за неделю. Массив вводится с клавиатуры.Ответы на вопрос
Отвечает Шатропова Полина.
//PascalABC.NET версия 3.3.1590 от 03.12.17
//Если программа не запускается, то обновите версию
begin
var a := ReadArrReal('Введите температуры за неделю', 7);
Writeln('Дней за неделю было с положительной температурой = ', a.Count(x -> x > 0));
Writeln('Дней за неделю было с отрицательной температурой = ', a.Count(x -> x < 0));
Writeln('Дней за неделю было с нулевой температурой = ', a.Count(x -> x = 0));
end.
//Если программа не запускается, то обновите версию
begin
var a := ReadArrReal('Введите температуры за неделю', 7);
Writeln('Дней за неделю было с положительной температурой = ', a.Count(x -> x > 0));
Writeln('Дней за неделю было с отрицательной температурой = ', a.Count(x -> x < 0));
Writeln('Дней за неделю было с нулевой температурой = ', a.Count(x -> x = 0));
end.
Топ вопросов за вчера в категории Информатика
Информатика 437
Информатика 11
Информатика 10
Информатика 44
Информатика 23
Информатика 43
Информатика 63
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
