Пожалуйста,помогите написать рабочую программу сцепления двух строк на Си++
Ответы на вопрос
#include <string>
using namespace std;
int main()
{
string st1, st2, st3;
cout <<"Введите первую строку: ";
getline(cin, st1);
cout <<"Введите вторую строку: ";
getline(cin, st2);
st3=st1+st2;
cout <<"Результат:" <<endl;
cout <<st3 <<endl;
return 0;
}
Конечно, я могу помочь вам написать программу на языке C++ для сцепления двух строк. Вот пример рабочей программы:
```cpp
#include
int main() { std::string firstString, secondString; std::cout << "Введите первую строку: "; std::getline(std::cin, firstString); std::cout << "Введите вторую строку: "; std::getline(std::cin, secondString);
std::string concatenatedString = firstString + secondString; std::cout << "Результат сцепления: " << concatenatedString << std::endl;
return 0; } ```
В этой программе мы используем библиотеку `iostream` для ввода и вывода данных, а также библиотеку `string` для работы со строками. Программа запрашивает у пользователя две строки и затем сцепляет их в одну строку с помощью оператора `+`. Результат сцепления выводится на экран.
Надеюсь, это поможет вам! Если у вас возникнут еще вопросы, не стесняйтесь задавать.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
