Написать программу pascal и excel, которая находит длину самого длинного слова в строке.
Ответы на вопрос
Чтобы увидеть программу жмите Alt+F11
var s,s1,s2,max:string;
i,k,maxdl,j:integer;
begin
readln(s);
s1:=concat(s,' ');
s2:=s;
maxdl:=0;
while pos(' ',s1)>0 do begin
max:=copy(s1,1,pos(' ',s1)-1);
delete(s1,1,pos(' ',s1));
if maxdl<pos(' ',s1)-1 then maxdl:=length(max);
end;
if length(max)>maxdl then maxdl:=length(max);
writeln(maxdl);
end.
P.s. немножко криво написано)) но работает.
Для решения данной задачи вам потребуется написать программу на языке Pascal, которая будет находить длину самого длинного слова в строке и выводить результат в Excel.
Вот пример программы на Pascal, которая решает данную задачу:
```pascal program LongestWord; uses SysUtils;
function GetLongestWordLength(inputString: string): integer; var longestLength, currentLength: integer; word: string; begin longestLength := 0; currentLength := 0; for word in inputString.Split([' ']) do begin currentLength := Length(word); if currentLength > longestLength then longestLength := currentLength; end; Result := longestLength; end;
var inputString: string; longestLength: integer; begin WriteLn('Введите строку:'); ReadLn(inputString); longestLength := GetLongestWordLength(inputString); WriteLn('Длина самого длинного слова в строке: ', longestLength); end. ```
Чтобы использовать эту программу в Excel, вам потребуется выполнить следующие шаги:
1. Откройте новую книгу Excel. 2. В ячейке A1 введите строку, в которой вы хотите найти самое длинное слово. 3. В ячейке B1 введите следующую формулу: `=LEN(A1)`. 4. В ячейке C1 введите следующую формулу: `=MAX(LEN(SUBSTITUTE(A1," ","|"))-LEN(SUBSTITUTE(A1," ",""))+1)`. 5. Нажмите Enter, чтобы вычислить результат. 6. В ячейке C1 будет отображаться длина самого длинного слова в строке.
Примечание: При использовании данного метода в Excel, учтите, что он будет считать пробелы в качестве разделителей слов. Если вам нужно учитывать другие символы в качестве разделителей, вам потребуется изменить формулу в ячейке C1 соответствующим образом.
Надеюсь, эта информация будет полезной! Если у вас возникнут еще вопросы, не стесняйтесь задавать их.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
