
напишите программу на языке паскаля через цикл while, которая определяет максимальное из введенных
чисел с клавиатуры(ввод чисел заканчивается числом 0).

Ответы на вопрос

var a,max:integer;
begin
max:=-10000;
readln(a);
while a<>0 do begin
if max<a then max:=a;
readln(a);
end;
writeln(max);
end.



Вот пример программы на языке Паскаль, которая определяет максимальное из введенных чисел с клавиатуры, при условии, что ввод чисел заканчивается числом 0:
```pascal program MaxNumber; var number, maxNumber: integer; begin // Ввод первого числа write('Введите число: '); readln(number); // Инициализация максимального числа maxNumber := number; // Цикл для ввода чисел и поиска максимального while number <> 0 do begin // Ввод следующего числа write('Введите число: '); readln(number); // Проверка, является ли введенное число новым максимальным if number > maxNumber then maxNumber := number; end; // Вывод максимального числа writeln('Максимальное число: ', maxNumber); end. ```
В этой программе мы используем цикл `while`, который выполняется до тех пор, пока вводимое число не станет равным 0. Внутри цикла мы сравниваем каждое введенное число с текущим максимальным числом и, если оно больше, обновляем значение максимального числа. После окончания цикла выводим найденное максимальное число.
Примечание: Программа предполагает, что пользователь будет вводить только целые числа. Если вам нужно обрабатывать числа с плавающей запятой, вам следует использовать тип `real` вместо `integer` и изменить соответствующие операции сравнения.


Топ вопросов за вчера в категории Информатика








Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili