Составить программу в Паскале Вклад в банке пролежал N лет. Процентная ставка составляет 10% в год
с ежегодной капитализацией. Насколько % увеличится вклад?Ответы на вопрос
program n_1;
var
a,X,e,f:real; N,b:integer;
begin
Writeln('ВВедите количество лет');
read(N);
Writeln('ВВедите сумму которую положите');
read(b);
X:=1+0.1;
a:=b*exp(ln(X) * N);
e:=b/100;
f:=a/e;
writeln(f,' ','процентов');
end.
Вот программа на языке Pascal, которая рассчитывает увеличение вклада:
```pascal program BankDeposit;
var deposit, interest: real; // вклад, процент
begin writeln('Введите сумму вклада: '); readln(deposit); // считываем вклад writeln('Введите количество лет: '); readln(years); // считываем количество лет interest := deposit * 0.1; // вычисляем процент writeln('Проценты за год: ', interest :0:2); // считаем результат с учетом ежегодной капитализации for i := 1 to years do begin deposit := deposit + interest; interest := deposit * 0.1; end; writeln('Конечная сумма вклада: ', deposit :0:2); writeln('Вклад увеличился на: ', (deposit - initial_deposit) :0:2); end. ```
Программа запрашивает у пользователя сумму вклада и количество лет, на которое вклад пролежал. Затем она вычисляет проценты за каждый год с учетом 10% годовой процентной ставки с ежегодной капитализацией. После окончания цикла программа выводит конечную сумму вклада и разницу между начальной и конечной суммой - то есть, насколько увеличился вклад.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
