Составьте программу( Pascal), которая заполняет массив a (1..10) случайными целыми числами от 1 до
20 и выводит на экран элементы, значения которых больше 5 и меньше 15Ответы на вопрос
var
a:array [1..10] of integer;
int:integer;
begin
for int:=1 to 10 do
begin
a[int]:=rndom(20)+1;
write(a[int],' ')
end;
writeln;
for int:=1 to 10 do
if (a[int]>5) and (a[int]<15) then write(a[int],' ')
end.
i:integer;
begin
for i:=1 to 10 do
begin
a[i]:=rndom(20)+1;
write(a[i],' ')
end;
writeln;
for i:=1 to 10 do
if (a[i]>5) and (a[i]<15) then write(a[i],' ')
end.
Конечно, вот пример программы на Pascal, которая выполняет задачу, описанную в вашем вопросе:
```pascal program FillArrayAndPrint;
const ArraySize = 10;
var a: array[1..ArraySize] of Integer; i: Integer;
begin // Инициализация генератора случайных чисел Randomize;
// Заполняем массив случайными числами от 1 до 20 for i := 1 to ArraySize do a[i] := Random(20) + 1;
// Выводим элементы массива, значения которых больше 5 и меньше 15 writeln('Элементы массива, значения которых больше 5 и меньше 15:'); for i := 1 to ArraySize do begin if (a[i] > 5) and (a[i] < 15) then writeln('a[', i, '] = ', a[i]); end;
readln; end. ```
В этой программе используется генератор случайных чисел для заполнения массива `a` случайными целыми числами от 1 до 20. Затем программа выводит элементы массива, значения которых соответствуют условиям "больше 5 и меньше 15".
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
