Сформировать массив с клавиатуры из N элементов (N - описываем как константу). Найти:а)
произведение.б) среднее арифметическое всех нечетных элементов массива.в) максимальный элемент массива.Выполняем в одной программе.Ответы на вопрос
n=10;
var a:array[1..n] of integer;
i,max,p,sr,k:integer;
begin
p:=1;
max:=1;
for i:=1 to n do begin
read(a[i]);
p*=a[i];
if odd(a[i]) then begin sr+=a[i]; k+=1; end;
if a[i]>a[max] then max:=i;
end;
write('P=',p,' Sr=',sr/k:3:2,' max=',a[max]);
end.
Для решения данной задачи, вам потребуется написать программу на языке программирования. Вот пример программы на языке JavaScript, которая выполняет требуемые действия:
```javascript const N = 5; // Количество элементов в массиве
// Функция для чтения чисел с клавиатуры function readNumber() { return parseFloat(prompt("Введите число:")); }
// Создание массива и заполнение его значениями с клавиатуры let array = []; for (let i = 0; i < N; i++) { array.push(readNumber()); }
// Нахождение произведения элементов массива let product = 1; for (let i = 0; i < N; i++) { product *= array[i]; }
// Нахождение среднего арифметического всех нечетных элементов массива let sum = 0; let count = 0; for (let i = 0; i < N; i++) { if (array[i] % 2 !== 0) { sum += array[i]; count++; } } let average = sum / count;
// Нахождение максимального элемента массива let max = array[0]; for (let i = 1; i < N; i++) { if (array[i] > max) { max = array[i]; } }
// Вывод результатов console.log("Произведение элементов массива: " + product); console.log("Среднее арифметическое нечетных элементов массива: " + average); console.log("Максимальный элемент массива: " + max); ```
В данной программе: - Константа `N` задает количество элементов в массиве. Вы можете изменить ее значение по своему усмотрению. - Функция `readNumber` используется для чтения чисел с клавиатуры. В данном примере она использует функцию `prompt` для получения ввода от пользователя. Вы можете изменить эту функцию в соответствии с требованиями вашей среды разработки. - После создания и заполнения массива значениями с клавиатуры, программа выполняет требуемые действия: - Находит произведение элементов массива. - Находит среднее арифметическое всех нечетных элементов массива. - Находит максимальный элемент массива. - Результаты выводятся в консоль с помощью функции `console.log`. Вы можете изменить способ вывода результатов в соответствии с требованиями вашей среды разработки.
Примечание: В данном примере использован язык программирования JavaScript. Если вам нужно написать программу на другом языке программирования, пожалуйста, уточните это.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
