Решите задачи( составить программы в Паскале). 1) По данным натуральным n и k вычислите значение
Cn/k=n!/k!(n−k)! (число сочетаний из n элементов по k). Входные данные Вводятся 2 числа - n и k (nk<=30 ). Выходные данные Необходимо вывести значение Cn/k . 2) По данному действительному числу a и натуральному n вычислите сумму 1+a+a2+...+an, не используя формулу суммы геометрической прогрессии. Время работы программы должно быть пропорционально n. Входные данные Вводятся 2 числа - a и n. Выходные данные Необходимо вывести значение суммы. 3) Входные данные Вводится натуральное число N, которое не превосходит 30. Выходные данные Вычислите 1+2+2^2+2^3+…+2 ^N.Ответы на вопрос
Я могу помочь вам с решением задач на Паскале. Вот мои ответы:
1) Для вычисления значения Cn/k=n!/k!(n−k)! можно использовать следующую программу на Паскале:
``` program Cnk; var n, k, i: integer; c: longint; begin readln(n, k); c := 1; for i := 1 to k do c := c * (n - i + 1) div i; writeln(c); end. ```
2) Для вычисления суммы 1+a+a2+...+an можно использовать следующую программу на Паскале:
``` program Sum; var a: real; n, i: integer; s: real; begin readln(a, n); s := 1; for i := 1 to n do s := s + power(a, i); writeln(s); end. ```
3) Для вычисления 1+2+2^2+2^3+…+2^N можно использовать следующую программу на Паскале:
``` program PowerSum; var n, i: integer; s: longint; begin readln(n); s := 1; for i := 1 to n do s := s + power(2, i); writeln(s); end. ```
Надеюсь, это вам поможет.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
